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Introduction 
This is a practical guide showing how to represent data visually using the Microsoft 

Excel spreadsheet package. It aims to act as a simple introduction to the software’s 

basic charting and graphing capabilities. It is not intended to be a comprehensive 

guide to all Excel’s options and features but will allow you to produce good looking 

and effective charts and graphs.  The guide assumes a basic familiarity with MS 

Excel; other spreadsheet software is similar so even if you don’t use Excel, the guide 

may still be helpful. 

This guide is designed to accompany our existing ‘Presenting financial and other 

management information effectively’ Good Practice Guide (GPG 27) which focuses 

on the key underlying principles of presentation. You might find it helpful to read 

GPG27 before continuing with this guide as the principles are not explained here – 

this guide deals simply with how to use the software. 

 

About the guide 
Microsoft Excel is both a powerful and complex software package. There are often 

multiple ways to carry out the same task. In practice many of the features available 

are not needed by the majority of users - so don’t worry if you don’t know what every 

button or option does – few do! In this guide we will tend to use options from the 

menu bar, but if you prefer to use the mouse, in most cases the same choices are 

available by right clicking the mouse. This guide has been developed using Excel 

2010 but is also appropriate for the previous 2007 version of the software. Earlier 

editions of Excel (2003 and before) will look and feel differently but should be broadly 

equivalent for the basic functions covered.  

 

Getting started 
Before you start, it is important you think carefully about the data you have and what 

and how you want to show it (please see GPG 27 for further explanation).  

Having done this preparation, before you can produce any charts you will of course 

need the underlying data! In this guide, we will use some very simple data to show 

Excel’s basic charting functionality – in this case some broad income headings – so 

enter the following simple income analysis into a new sheet: 
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Highlight your data – in the above case this would be cells A3 to C7 

 

 

In menu bar at the top of the screen, you will find the ‘Insert’ heading. Clicking on this 

option will change the icons in the menu bar below and give access to the various 

charting options – you should see icons representing some of the different charts 

available inclusing ‘Column’, ‘Line’ and ‘Pie’. (please note - GPG27 – explains what 

these different chart types are and what they are best used for). 

 

 

 

 

From this point, you can generate any of these chart types by simply selecting the 

relevant icon. In this example, we are producing a bar chart, so click on the ‘Bar’ 

icon. This then gives a further selection of a wide range of different types of bar 

chart.  

 

 

 

 

 

Note: some later chart formatting can 

be avoiding by formatting the data 

first – eg including data with currency 

(£). We have avoided this to show a 

broader range of chart options. 
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Your screen should look like this (which also summarises the steps so far):   

 

 

 

We will pick a simple 2-D(imension) bar chart – which is the first option (top left in the 

drop down box) – so click on this 2-D bar icon. 

Tada! –Excel will then automatically produce your first chart (as shown in the image 

below). However, the default Excel settings are not ideal –so don’t leave it here. For 

example, the standard colours offer poor contrast and are not particularly clear, try 

printing them in black and white! 

 

Clicking on any 

chart icon will give 

a range of charts of 

that type 

1) Select 

‘Insert’ 

2) Pick ‘Bar’ 

3) Click ‘2-D Bar’ 
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The chart is currently embedded as an object within the spreadsheet – it is easier to 

manipulate and work with it when it is a separate sheet within the spreadsheet (eg it 

is bigger). Click on Move chart (top right of above) and then click on move to sheet 

– your chart should now be full screen and become chart 1 as a tab at the bottom of 

the screen (you can rename it by right clicking the tab). 

Your screen should now be showing a full size chart as in the image below: 

 

 

You can also 

‘Move Chart’ 

by right-click 

of the mouse 

Click ‘Move Chart’ 
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You are now in a position to start editing and improving the chart’s presentation. You 

can make most of the basic changes using the options available from the ‘Layout’ 

main menu bar item.  

Clicking on the ‘Layout’ menu item will bring up a range of icons enabling you to 

make changes to the look and feel of your chart. 

 

‘Layout’ menu bar item 

 

 

 

We will run through a range of formatting options –although these are itemised in a 

series of steps, in practice there is no specific order that actions need to be carried 

out in, this is very much down to personal preference. 

1. Chart Title 

2. Axis Titles 

3. Legend 

4. Data Labels 

5. Axes 

 

1. Inserting a chart title 
From the Layout menu – click the ‘Chart Title’ icon. This will then give a range of 

additional options. For now, simply, click ‘Above Chart’ from the drop down box: 

 

 

 Click ‘Above 

Chart’ 

1 2 3 4 5 
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You should now have a small rectangular text box above your chart with the words 

‘Chart Title’. Clicking in the text box will allow you to edit the text and insert the 

wording for your own chart title. 

It is easy also to change the font size or type – depending on your preference, this 

can be done either by: 

• Clicking on the ‘Home’ menu bar item – which then gives you a range of font 

options in the menu bar 

• Right clicking in the text box – which brings up the same font options 

 

2. Amending the axis title 
Our sample chart has two axes – the horizontal (‘x’) axis represents a monetary 

value, and the vertical axis (the type of income). It is good practice to ensure that 

axes are labelled to help the reader understand the chart clearly. 

To insert an axis title: 

 

In the ‘Layout’ menu item select ‘Axis titles’. You will have the option to edit both ‘x’ 

and ‘y’ axis and be given a range of alternatives. 

In this case click ‘Title Below Axis’ 

 

 

 

This will result in a text box below the ‘x’ axis which says ‘Axis title’. As in the case 

when amending the chart title, you are then able to edit the text box to include a 

relevant title (in our example it might be something as simple as - ‘£’). In a similar 

way you are able to alter font type and size to suit your needs. 
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3. Formatting the legend 
The chart legend explains to the reader what the individual data series are. In our 

example, we have two series – budget (currently represented by the blue bars) and 

actual financial data (by the red bars). 

You will see from the screenshots earlier in this guide that by default a legend is 

automatically included in the chart when it is initially generated; it is shown more 

clearly in the chart extract below: 

 

 

 

Next to the Axis titles icon (again in the Layout menu item), there is the Legend 

button. Clicking on this button will bring up a drop down box with multiple options. 

Essentially, these give you the choice of where in the chart to have your legend 

(remember it is on the right by default). Showing the Legend at the bottom is a 

common alternative option. You can also choose ‘None’ to remove the legend – this 

will resize the bars and make them slightly bigger. 

 

Chart legend 
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As with the other formatting options covered, it is possible to format the legend font 

type and size using by clicking the ‘Home’ menu bar item at the top. 

4. Inserting Data Labels 
Data labels are the numbers and other data which are used to generate the chart. So 

for example, in our example, these are the numbers you entered in the initial 

spreadsheet. Sometimes it can be helpful to include these values together with their 

graphical representation (for example individual bar or pie slice). 

Again the ‘Data Labels’ option is accessible from the ‘Layout’ menu. Clicking on 

‘Data Labels’ will result in a drop down box which offers a range of locations for your 

data; this includes both inside and outside of the bar as well as in the middle.  

 

You can also edit the legend by 

clicking on it. For example, to 

remove it hit the delete button 

when you see the handles around 

the box. You can also resize and 

format the legend text this way. 
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For simplicity this has guide has stayed away from the additional options at the 

bottom of the drop down box in the examples shown to date. In the case of ‘data 

labels’ it is worth briefly exploring this option a little further: 

Selecting ‘More Data Label Options’ brings up a further dialogue box – Format 

Data Labels: 

 

 

Location choice may be 

influenced by other formatting 

decisions (for example, if 

including the data item inside 

the bar slice, make sure numbers 

are clear to read – ie the font 

colour doesn’t clash with the 

colour of the bar or pie). 

To format the data – pick 

the ‘Number’ option on the 

left. This will allow you to 

select currency – (£) to show 

financial values. 
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This gives you greater flexibility and enables you to enter additional information, for 

example: 

• Category name (in our case this would be income type – for example ‘Grant’); 

• Series name  (in our case, this would be ’Budget’ or ‘Actual’) 

Sometimes it can be helpful to include this additional information within the chart 

itself (ie in or next to the bar) as it may allow you to remove the individual axes titles. 

 

5. Editing the axes 
You can make changes to an individual axis by selecting the ‘Axes’ icon from the 

Layout menu. 

 

 

 

This drop down menu gives a range of choices and will enable you to show the 

relevant axis to a particular scale (for example in thousands), the axis will 

automatically be rescaled (this will also be the case for any data labels you have 

already inserted). 

Selecting ‘More Primary Horizontal (or Vertical) Axis Options’ in a similar way to 

the equivalent additional ‘Data Label options above, will give you greater flexibility 

over the axis presentation. For example you can manually set the scale and also 

format the numbering choice (including for example, currency for financial values). 
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6. Changing chart data colours 
Excel’s default colours when generating the sample bar chart used in this guide are 

red and blue. These are not necessarily the best options for presenting information 

(for example, as you will see if you have to print the chart in black and white!). 

However you are not restricted to using these default colours and can change the 

colours used in your bar, pie or other chart. 

You can change colours by either using the pre-prepared Excel template options or 

manually selecting your own choices. 

Excel template options 

Under the ‘Design’ tab In the menu bar above the spreadsheet window, there are a 

number of pre-defined coloured themes for your bar chart – typically offering 

variations of shades of the same colour. This can been below: 

 

 

 

 

You are not limited to just those choices you can see in the menu bar – this is a drop 

down box and by clicking on the down arrow, you will find a much larger selection – 

including choices with different coloured backgrounds. 

You can change to any one of these themes by simply clicking on the relevant icon – 

your chart will be automatically updated with your choice. 

Manual selection 

Making the changes yourself gives you greater flexibility in choice of colour and 

allows you to select those which contrast well to give your charts better impact. 

To alter the colours manually: 

1) Point the mouse over one to the bars (say blue in this case) and left click the 

mouse button once (this will select all the bars in that data series – you can 

check this by looking for the small circles in each corner of the bar) 

2) Select the Format menu item in the Chart Tools section of the main menu bar 

(at the top of your screen) 

3) Click on the small drop down box next to the ‘Shape Fill’ option  

 

Design menu heading Drop down box 



GPG No 29: Using charts in Microsoft Excel 

 

 

13 
Copyright: WYCAS This Document may be reproduced in whole or in part subject to 

acknowledgement of source 

 

   

4) You will then be able to select from any of Excel’s default colours or make 

your own (‘More Fill Colors’). Within this menu option, there are a host of 

other ways to tailor the look of the bars (including changing textures, inserting 

pictures etc). In most cases, a solid fill will be the best and clearest option. 

 
Conclusion 
This guide has given a brief introduction to some of the basic but most important 

charting options available. It is not designed to be fully comprehensive guide to all 

Excel’s functionality and there is no substitute for practice and regular use. The best 

way of consolidating learning is simply to explore and have a play with some of the 

available options to see what works well for you. 

Further support 
WYCAS regularly runs training courses on financial reporting which covers the 

principles and practice of presenting financial information. WYCAS community 

accountants can also visit your organisation to provide specific tailored one to one 

support and help in any of these areas. Further information and contact details are 

available on our website – www.wycas.org.uk 

A pattern fill may be a good choice 

for printing in black and white: 

To do this click on: Textures/More 

textures/Pattern fill 
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Appendix – Sample bar chart 
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